re = /(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\:\/\/[\w\.]+(?:\:?\d{0,5})|(?:mailto|)\:[\w\.]+\@[\w\.]+/
str = 'http://www.site1.com/perma/doom-rock.htm
http://www.site2.net/mod/doom.html
https://www.site3.com/m/doom-rock
http://site4.com/doom
https://site5.com/doom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end