$re = '/^0+(?=\d)/m';
$str = '0
05 5
505050505
00005
000000000000000005555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);