#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(Where|How|Is|Does|I wanna|I want|I wish)\b.*\bdemo( game| version( of the game)?)?( exist| available| out there)?(\.|\?|!)*?$"
Local $sString = "How can I download the demo" & @CRLF & _
"Where get demo?!?!" & @CRLF & _
"where is the demo version of the game?" & @CRLF & _
"How do I get the demo game!" & @CRLF & _
"Anyone know how to get the demo?" & @CRLF & _
"How does one download a geneshit" & @CRLF & _
"so I was wondering, how do we get more newbies to play the demo" & @CRLF & _
"Does a demo version of the game exist?!?!?" & @CRLF & _
"Is a demo version of the game available" & @CRLF & _
"is a demo version of the game out there" & @CRLF & _
"Is there a demo version?" & @CRLF & _
"I wish there was a demo version" & @CRLF & _
"is a demo out there?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")