import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!空)(调|换)(个)?.{0,5}(房间|房)";
final String string = "全部不安排了那个浴巾毛巾,要,要,要换了。\n"
+ "哎呀,我们这个房间没有帮我们清理房间收拾房间吗?那个浴巾那个床被什么都没有换吗。\n"
+ "哎,我那个清理没水,我这个房间我想一个呢,你看看能不能帮我来弄一下的二个呢,到时候今天的话能不能给我换个房间。\n"
+ "你叫那个工程部还是的,给我换一下店保险箱换一下电池。\n"
+ "保险箱换电池。\n"
+ "他就个字这样吗?就是就就搞得那高大上一点发射电话机换。\n"
+ "嗯,你好,我想换那个南向的房间可以吗?\n"
+ "我换的电视节目。\n"
+ "我那个我们这个房间是三三要二三是这个我这个吹风机啊,室外的能换一个吗?\n"
+ "未我是吹风机是坏的,能换一个吗?\n"
+ "不是简单切换到前台。\n"
+ "换枕头。\n"
+ "你怎么不你们之前进来一个都没有,你,我配一个的,我拍一个十个八个正好住这几天一天差不多的一个吧,都换一个吧。\n"
+ "嗯,那个我想换一间房。\n"
+ "我是六二零一房间,然后那个就是小孩啊的个在那个床上,然后我想换一下床单。\n"
+ "换床单。\n"
+ "空调房间\n"
+ "不要换个头。\n"
+ "我要我要换个枕头。\n"
+ "我要换个房间。\n"
+ "嗯,换换遥控器。\n"
+ "嗯,什么我的,我是三幺零房间,我需要把这个店的冰箱把那条一下就是早上的换乘冷气。\n"
+ "我想换间房。\n"
+ "啊,我那个需要换那个桶装水。\n"
+ "你好,那个承担失了麻烦帮我换一个。\n"
+ "床单是了,麻烦帮我换一个。\n"
+ "我的遥控器坏了,帮我换一个。\n"
+ "啊,你看那个我这个房间这个遥控器啊,这个今天昨天晚上说是今天给我换一个,我看也没换呢,还是不行啊。\n"
+ "把那个浴巾都给我换一下。\n"
+ "显示才抽屉那个订书器太小了,不够用了,换一个大的。\n"
+ "呃,换房。\n"
+ "我的暖水壶坏了,给我换一个到现在都不开水。\n"
+ "不用吧,要七那个能,能帮我换一下高一点的那个房子吗,不要要在砖头的?\n"
+ "嗯,换一下,崇尚备品。\n"
+ "对,现在没有安排地卫生换被罩备品。\n"
+ "帮我这换一下这个被子的那个床单备注。\n"
+ "嗯,麻烦您九五要换一下床单被单枕套就行了。\n"
+ "现在把床单和被套重新换一套换个新的就是重新换一下,都是房间就行了。\n"
+ "这换一个电茶壶。\n"
+ "嗯,请修理一下空调房间空调?\n"
+ "嗯,那个我能换到那个明示阁豪华大床房吗?就这个房间的小。\n"
+ "换房间。\n"
+ "帮我换一个床单和被套。\n"
+ "咱这的过来,把那个传单换一下这么脏,怎么设呀?\n"
+ "帮我这边九二零打扫卫生,就是垃圾桶地垃圾还有浴巾这些换的其他的就可以了。\n"
+ "我的意思是,是说让这些东西换掉就是说今天清理房间?\n"
+ "那个我想换一个政策的正常太高了,还想要个儿童床。\n"
+ "说是买一换钱,小孩的来了一不会大家说的。\n"
+ "我已经订过了,这是换了个房间才能给我送来吗?\n"
+ "换个房间。\n"
+ "拖鞋,我洗澡的时候是了,现在要重新换洗涑用品,我那个入住以后洗澡已经用过了,现在没用,所以现在要重新要两套。\n"
+ "行,换一下床单。\n"
+ "想换难怪。\n"
+ "嗯,需要更换一下,这个烧水的壶。\n"
+ "需要更换一下。\n"
+ "啊,那个上岸要房间要那个水,然后来换一下毛巾。\n"
+ "需要换毛巾。\n"
+ "嗯,水果还有那个换洗干洗的衣服?\n"
+ "嗯,能不能给我换个房间啊。\n"
+ "啊,就是帮帮忙看一下那个那个东西也没换呀,或者嘉里水进来也可以。\n"
+ "房间打扫一下,城镇换了。\n"
+ "不能烧水换了。\n"
+ "嗯,用完了,因为我在这边出了将近一周了,然后好多东西都没换呢,就是我补充下就行了。\n"
+ "你好,麻烦把五零五的床单给他给换一下,下午。\n"
+ "嗯,我要这个换一个加湿器。\n"
+ "嗯,送两瓶换乘水给我。\n"
+ "嗯,能换房吗?\n"
+ "换乘水有着。\n"
+ "只用完了,能换一下能,能,能换一包吧。\n"
+ "地下不是换了一个,我以为是加湿器的那个不知道是什么的。\n"
+ "可以换一个附近枕头或者荞麦枕头吗?\n"
+ "对,现在需要换乘的。\n"
+ "换床单。\n"
+ "条条换一个房间。\n"
+ "你好,麻烦过来帮我整理一下房间吧,把传单被套的换一下。\n"
+ "能不能换一个人来接电话呀。\n"
+ "我想换一下床单。\n"
+ "嗯,换个针头。\n"
+ "嗯,换一下被套。\n"
+ "嗯,能来一个服务员来我换一下床吗?\n"
+ "我要换一下房间。\n"
+ "亲,换人工好吗?\n"
+ "换一个妹子。\n"
+ "您好,我想那个叫客房佈置,我,我想换房间。\n"
+ "你好,我想通知一下打扫房间的阿姨,我是八二六房间,我不需要打扫卫生,需要换毛巾就可以了。\n"
+ "您好,可以换一个方便吗?\n"
+ "换一个房间。\n"
+ "我想问一下有房间可以换吗?\n"
+ "我需要换一把椅子?\n"
+ "那个帮我们换一下承担。\n"
+ "我这个我的空调怎么光能房没有夜风啊。\n"
+ "我北京的了,这是换个水杯。\n"
+ "房间需要打扫床单被套更换。\n"
+ "嗯,我要换床单。\n"
+ "帮我换一个好一点的房间,这个房间步行。\n"
+ "换房间。\n"
+ "嗯,你那个那个饼干是免费的吗?冰箱换上。\n"
+ "我想换个房间。\n"
+ "华为充电线这个坏的重新换一个好不好。\n"
+ "换房吧?\n"
+ "换乘单。\n"
+ "换床单。\n"
+ "换一首歌。\n"
+ "换一首歌。\n"
+ "换房间。\n"
+ "想交换房间,请转人工。\n"
+ "嗯,充电器不好使,然后换一个。\n"
+ "那个房间房间有味道能不能换个房间。\n"
+ "我想换一个房间。\n"
+ "换一个水壶水壶坏掉了。\n"
+ "那个我们同事五二三那个房间,他那个卡换了一次还是不好使,你们可不可以派人上去一下。\n"
+ "啊,是这样的,就是我那个刚入住的房间,但是我这房间一直有一个声音怪怪的一小,我觉得很难受能不能帮我换个方便。\n"
+ "我想换间房。\n"
+ "喂,你好,那个我刚入住这个房间,我想换一个就是不是把边的房间有吗?\n"
+ "嗯,过来里边建水,你今天没有房间里今天没有换过建水。\n"
+ "嗯,刚刚送过来一条那个苹果手机充电线,但是充不上电不好用,是不是帮我们重新换一调呢。\n"
+ "那个今天没有给我换新的。\n"
+ "是风筒坏了,请帮我换一个。\n"
+ "我这个卫生也没打扫开送都没送,该改换的都没换。\n"
+ "更换一同水。\n"
+ "两个床单两个床的床单都要换掉。\n"
+ "床单被套都要换掉。\n"
+ "我想换一间房子今天。\n"
+ "嗯,你好,需要更换个快乐。\n"
+ "换换一下新的东西把里面的水什么的换下。\n"
+ "你把这个流量要这个床单给换一下吧。\n"
+ "您是退换可以到七点。\n"
+ "换一下人工服务吧。\n"
+ "喂,你好,我那个房间的是有接不了,是换乘还是现在帮我弄啊。\n"
+ "换房。\n"
+ "哎,你好,我这边的那个烧水的和是坏的过来换一个。\n"
+ "你,你好,我想问一下,咱们这个空调怎么开房呢?\n"
+ "调整房间里问住房在中泰的。\n"
+ "可以换一下房间吗?\n"
+ "嗯,你好,麻烦换人工服务。\n"
+ "换一下。\n"
+ "给我换了吗,毛巾两个呃,两个两个带一个毛巾。\n"
+ "床上用品要更换。\n"
+ "打基础,我能不能换房这个,这个排水不行了,那个下水道不去的,你这处理,处理不了啊,我在有人在里面洗澡啊。\n"
+ "要换一桶桶装水。\n"
+ "哎,你好,我想换个房间。\n"
+ "我换个枕头。\n"
+ "喂,你好,我的房间是三八就是我们那个刚才用那个就是那个房间那个确认九点问题,咱们让他们那个就是修理主人发来看一下或者给我们换一个登机。\n"
+ "嗯,我吹风机,我问题让他换一个过来。\n"
+ "好,这边幺幺幺六可不可以帮忙换一下,毛巾,然后送两双一次性脱鞋。\n"
+ "我想换一个房间。\n"
+ "有换人工?\n"
+ "换一下床单。\n"
+ "诶,你好,是这样的,我这房间应该老然后刚才那服务员过来,他们空调调太低了,刚开到我看开了也不怎么能给我换一下吗?\n"
+ "嗯,要求他预订怎么换调预定毛巾了,谢谢。\n"
+ "想换个房间。\n"
+ "你这个服务员来看,看,我这个遥控器电视怎么不能换台。\n"
+ "我空调房间里的空调不热。\n"
+ "换床单。\n"
+ "哎,你好,我这个三六八房间的吹风机坏了,能帮我换一个吗。\n"
+ "嗯,换小彭机器人送一个指甲刀到要七二三房间。\n"
+ "我换个卫生纸。\n"
+ "好,可以换一间房吗?\n"
+ "换房间。\n"
+ "嗯,我这个需要换床单。\n"
+ "我换一下。\n"
+ "就是我们洗澡的那些毛巾要换一下,还有拖鞋。\n"
+ "更换。\n"
+ "我想换房间。\n"
+ "换一下床单。\n"
+ "换床单。\n"
+ "给我换个房间转一下前台。\n"
+ "换一下床单。\n"
+ "帮我找老婆房间换床单,被罩浴巾毛巾。\n"
+ "你好,那个换个房间房间的公园不了。\n"
+ "哎,你好,那个我那房间里,呃帮我换换个诶的。\n"
+ "啊,就是我想换一个或者是怎么着?\n"
+ "不需要了,华为的换为充电线。\n"
+ "嗯,但是没有要换一下。\n"
+ "换一经。\n"
+ "条换房间。\n"
+ "那个我不好意思,我问一下那个能帮我调个房间吗?\n"
+ "嗯,你好,我昨天已经用过了,能不能给我换个新的牙刷。\n"
+ "我想那个这个都可以换一下换那个小卖店有吗?\n"
+ "我说那个这换一下是一的全面里头。\n"
+ "我的现在空调很热房间。\n"
+ "我需要两个替换用地垃圾的。\n"
+ "我要换一个房间。\n"
+ "加湿器换了。\n"
+ "换洗床单被罩。\n"
+ "是换一下床单和被罩还有枕头的套子。\n"
+ "能这边给我们换一首儿哥们。\n"
+ "更换床单被罩。\n"
+ "为我们的电视换不了。\n"
+ "换人工。\n"
+ "您好,我想换房间。\n"
+ "啊,就是我这个房间现在可以换个标间吗?\n"
+ "我想直接换个换个标间。\n"
+ "嗯,我要换一个枕头,想换个荞麦枕。\n"
+ "嗯,这个房间有sp插口发展需换一个。\n"
+ "帮我转一下前台,我换个房间。\n"
+ "我们跳闸了然后水壶帮我们来换一个。\n"
+ "呃,您好,我们现在是那个住在九一八的那个大床房,然后我们想换回标间。\n"
+ "些床单被单啊,这些是所有的全部都换了好吗。\n"
+ "全部都换掉好吧。\n"
+ "就把床单整套那个什么被被套全部换了好吧。\n"
+ "嗯,你好,我想问一下退换一个房间吗?\n"
+ "我换一个楼层高一点的房间。\n"
+ "麻烦问一下那个给我换个高一些的房间行不和成高一点的?\n"
+ "啊,我想把双床房换成大床房。\n"
+ "我说我这个房间能不能给我调换一下。\n"
+ "能不能给我换一下房间条换一下房间。\n"
+ "嗯吧,浴巾换一下。\n"
+ "把浴巾换一下。\n"
+ "给我换个中央五台。\n"
+ "喂,那个帮我换个房间,我不要这个房间。\n"
+ "我要换房。\n"
+ "好不,我们换一下那个床单。\n"
+ "您好,帮我垃圾倒来换一下。\n"
+ "不用,就是把床单换一下行了啊。\n"
+ "为方便的时候把那个床单换一下吗?\n"
+ "能给我换个房间吗?\n"
+ "给我两个幺三幺七零八这个不换水。\n"
+ "可以帮我们换个房间吗?\n"
+ "就是现在不不是不是坐清洁吗,然后我就想没有清洁带到时候我们要换怎么弄啊。\n"
+ "现在打扫房间送换一下床单儿之类的好吧。\n"
+ "我想换一间房。\n"
+ "要换新的。\n"
+ "麻烦帮我换一个新的浴巾和毛巾。\n"
+ "你好,那个什么,我那个我看到我的柜子很脏,换过吗?\n"
+ "那个换一下床单被子吧,被单。\n"
+ "空调换。\n"
+ "空调房间\n"
+ "嗯,没有把反您那个东西都换一下。\n"
+ "要续房间换房间。\n"
+ "我送两瓶空调水到我房间。\n"
+ "你好,我这屋里的水壶坏了,这换个是有工作这么满天。\n"
+ "我要换一间房间。\n"
+ "我想换房间太吵了。\n"
+ "啊,我这个房间里的吹风机是坏的麻烦你帮我换一个信号的。\n"
+ "嗯,我需要更换床头的充电用se。\n"
+ "换乘,但是被罩。\n"
+ "太小了房间,我要换房间。\n"
+ "我不换房间吗?现在可以换吗?\n"
+ "这个房间的气味很大。我想换一下房间。\n"
+ "我的房间那个水壶是坏的换乘水壶。\n"
+ "换乘被子。\n"
+ "嗯,能否再给我一个那个袋子换了。\n"
+ "你好,我要我我换房间。\n"
+ "啊,需要换一下,毛巾。\n"
+ "换一个充电线。\n"
+ "我们已经用过来在给我们换两套浴袍。\n"
+ "给我们换两套。\n"
+ "给我们换两套浴袍。\n"
+ "型换成头?\n"
+ "哎,九零六天天要换一下,这些床上用品。\n"
+ "那个八零五换一下垃圾箱,好吗?\n"
+ "你好,那个赶快让她们给我换一下床单被罩这张床,然后我是后入住的,因为我要住这然后现在传单没找时尚,一个客人住的,我要更换。\n"
+ "更换床单被罩。\n"
+ "你好,我问一下调换房间怎么联系?\n"
+ "我要换一个房间。\n"
+ "不是六点钟二十三点我们是昨天入住的今天,不应该在换换一次这个直饮水吗?\n"
+ "你不是应该每天都换吗,知道我们昨天入住的。\n"
+ "你好,上午没有打扫房间,然后水什么都没换叫服务员,拿两瓶水过来吧。\n"
+ "嗯,要两个润肤露,还有更换浴巾。\n"
+ "我要两个人符合更换浴巾。\n"
+ "更换已经。\n"
+ "请问有没有早餐是那个换卡。\n"
+ "嗯,床单被套都要换一下。\n"
+ "换乘水。\n"
+ "么急事呀,能换一种说法吗?\n"
+ "帮我送积分换中水上的。\n"
+ "您好,我需要换一个荞麦枕。\n"
+ "嗯,那个不是七五六把那个我童五的那个礼盒那个丽池换一下。\n"
+ "嗯,我想就是给房间啊,就是换一个那种荞麦的枕头。\n"
+ "我想换个房间。\n"
+ "唉,你好,嗯,是这样的,我这边前面就是换了一间房吗,要五零五换到要六三,然后那个房卡给我一张,但是这里就是。\n"
+ "我的房卡好像磁性不够了给我换两个。\n"
+ "我说我的房卡,那没有磁性了给我换两个。\n"
+ "我,我想换个好点的房间有没有?\n"
+ "呃,换房间。\n"
+ "换个枕头儿童的枕头。\n"
+ "换个枕巾。\n"
+ "换房间。\n"
+ "就是把床单被套整套换了最后在在要西城地板机场。\n"
+ "我转前台,我要换床单,二四幺六。\n"
+ "兑换标间吗?两张床。\n"
+ "我要上算了标间换房型。\n"
+ "空调房间好像不热。\n"
+ "你好,可以换钱吗?\n"
+ "我打扫房间,然后把那个洗淑用品的换一下。\n"
+ "换床单。\n"
+ "我要换房。\n"
+ "你,我是那个我要吧,房间我那个房间的热水壶,不好使下去麻烦帮我换一个。\n"
+ "喂,我想换一个好豪华大床房。\n"
+ "嗯,我想换一个大额豪华大床房可以吗?\n"
+ "我那个房间的热水壶,不好使,现在能不能马上更换一下。\n"
+ "换一下毛巾。\n"
+ "哪里的换人水吧。\n"
+ "嗯,我能不能换个房间。\n"
+ "呃,换床单和被罩。\n"
+ "嗯,针头换一个。\n"
+ "换一个数。据线。\n"
+ "嗯,现在安排,然后换一下床品。\n"
+ "小换,我找小刘。\n"
+ "就是换乘水给我拉了两百到。\n"
+ "再帮我换一下房间的垃圾桶。\n"
+ "要九二五房间帮我拿两个新的浴巾和哪一个小的毛巾和帮我换一下垃圾桶。\n"
+ "你好,那个客房里的饮用水没有了,能不能给换一个。\n"
+ "能不能不能换两条用过了,能能换两天。\n"
+ "语音能不能换两条浴巾。\n"
+ "那个幺零零幺幺零六八换两条浴巾送一个的刮胡刀,可以吧。\n"
+ "换房间。\n"
+ "我的针头不说什么能给我换个荞麦枕啊,或者是什么薰衣草枕头啊,稍微有点硬的枕头行吗?\n"
+ "你昨天晚给我送那个充电线不好用,你能给我换个条。\n"
+ "我的空调电脑控制的那个灯关是房间有十一。\n"
+ "我想调换一下房间。\n"
+ "哎,你好,那个是这样哈,我我刚入住那个房间那个啊,我跟你说我感觉不接是摔倒了,你看能不能给我换一个意思。\n"
+ "额,你这边空调的那个房间空调好像只能吹风不制冷是吧?\n"
+ "嗯,换一床被子吧。\n"
+ "嗯,你好,可以换一下被子吗?\n"
+ "空调不能制冷房间很冷。\n"
+ "我们这空调为什么不能上不来啊,你们这这么冷的房间,这十九度块钱啊。\n"
+ "我想换房间。\n"
+ "我要换个房间。\n"
+ "我要换房间?\n"
+ "空调关上吧,要六房间的空调?\n"
+ "嗯,那个换个床单么,我那个刚住进来,幺六幺五那个那个一下上面好像没什么。\n"
+ "叫服务员来帮我换一下,换一下床单被套全部换一下。\n"
+ "嗯,帮我把那个我那个房间那个全换一套传单被套。\n"
+ "能不能帮我叫一下客房服务来帮我换一下,这个床单的。\n"
+ "就是换换衣柜里面的袋子。\n"
+ "打扫一下房间床单被罩换一下。\n"
+ "哎,你好,我这个啊,我这空调维修部到怎么开,你们服务员帮我开一下的,还有这个个垃圾袋换个。\n"
+ "换位。\n"
+ "不是,我刚才不是跟你说了吗,那个床床单成人过来换一下。\n"
+ "打扫房间换床上的用品。\n"
+ "你好,我要换房。\n"
+ "我要我我一下有没有其他房子可以可不可以换房间。\n"
+ "喂,你好,我房间老是如果未就是能不能换个房间啊。\n"
+ "嗯,可以换浴巾,还有那个那个今天的水还没给啊。\n"
+ "换垃圾。\n"
+ "床上用品要更换。\n"
+ "更换床上用品。\n"
+ "除了打扫还有更换床上用品。\n"
+ "都换一下啊。\n"
+ "给我送的那个充电器线给我更换一个那个充电器线不能用。\n"
+ "换一个音乐?\n"
+ "麻烦给我打扫房间换床单,被罩。\n"
+ "这个呃能能换个房间。\n"
+ "唉,那个就是我重新定了一个大床房,然后然后要调房吗?还是说可以,不用交款。\n"
+ "就是那个苹果手机的话,那个换卡那个卡片。\n"
+ "我早一下客房服务,或者说换个枕头找谁?\n"
+ "嗯,我们要九零吧,想换个有两张床的房间可以吗?\n"
+ "换乘单。\n"
+ "现在帮我换成单。\n"
+ "嗯,打扫卫生换个床单被罩。\n"
+ "我现在是这是个两个床的房间,我想换成大床房。\n"
+ "我要换一个房间。\n"
+ "我,我要热水壶坏的,没有电了,要换热水壶。\n"
+ "我想问一下那个空调和那个房间的大灯的怎么打呢?\n"
+ "换人工,谢谢。\n"
+ "我我换两个荞麦皮的枕头,幺五零六。\n"
+ "我的被子,这里很脏,需要来换一下。\n"
+ "我这边一个有张卡取不了电,怎么换卡。\n"
+ "你好,我那个要二五要能换一个房间吗?是二楼的大床。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}