import Foundation
let pattern = #"[a-z0-9.\-\s]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖
Ra.ndri anjafi. mahtr-atra1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)