$re = '/(?<!^| ) (\w+?)(?:\r\n?|\n|\z)/';
$str = 'Some line of text ending witha line terminator
Always find the lsat word with or without a line terminator not including a space
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);