const regex = /IE(?:[\d]{7}(?:[A-Z]{1,2})|\d[A-Z][\d]{5}[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('IE(?:[\\d]{7}(?:[A-Z]{1,2})|\\d[A-Z][\\d]{5}[A-Z])', 'gm')
const str = `IE1234567U
IE1U23456U
IE1234567UU`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}