$re = '/^ (JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC) (MON|TUE|WED|THU|FRI|SAT|SUN) (19|20)\d\d $/m';
$str = ' FEB MON 2023 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);