re = /(?P<utm_term>(?<=utm_term=).*?(?=&|\\s|$))/m
str = 'https://www.rover.com/search/?utm_medium=email&utm_source=Responsys&utm_campaign=111017190001&utm_content=2017_11_09_O_TGiving_NoSt_SDTest_NoCoup_2&utm_term=111017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end