package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ugi=(?<ugi>[\w]+)\sip=(?<ip>[\S]+)\scmd=(?<cmd>[\S]+)\s(?<method>[\S]+)[\s]?:\s(?<details>[\S]+)`)
var str = `ugi=flink ip=172.18.214.55 cmd=source:172.18.214.55 alter_table: hive.net_seed.netdebugnetworkconnectionstatereadysnapshotcapturedevent newtbl=netdebugnetworkconnectionstatereadysnapshotcapturedevent
ugi=root ip=172.19.212.146 cmd=source:172.19.212.146 get_table : tbl=hive.nlx_dev.marrsqueryrewritecontextevent `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}