$re = '/\bi\b/';
$str = 'i\'m replacing it. am i not?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);