re = /^(([0-9])|([0-2][0-9])|([3][0-1]))\ (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\ \d{4}$/
str = '12 Jan 2014'
# Print the match result
str.match(re) do |match|
puts match.to_s
end