$re = '/(?i)\w{3}(?<!mon)ster/m';
$str = 'Munster
monster
Monster
Teester
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);