re = /^(-?\d*)([a-zA-Z])\^2 *([+-] *\d*)\2 *([+-] *\d+) *= *0$/
str = '-x^2 + 5x + 15 = 0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end