re = /^\d{3}-\d{2}-\d{4}$/m
str = '555-55-5555
11111111
111-111-1111
111-22-5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end