package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A\d?[a-zA-Z]{1,2}\d{1,4}[a-zA-Z]{1,3}\Z`)
var str = `AE0MW`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}