const regex = /^[ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,23}[\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}[\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,23}[\\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}[\\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}$', '')
const str = `Qəüöğ Üddsfs Üeredgd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}