#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi) <a id="(.*?)<\/a>"
Local $sString = "{% comment %} " & @CRLF & _
"Use this template to create the Appian_Release_Notes.md page for each new version of Appian. Any changes to this template should be discussed with the Information Development team. " & @CRLF & _
"{% endcomment %}" & @CRLF & _
"" & @CRLF & _
"New features are described below in detail. Behavior changes, resolved issues, deprecations, and removals are called out their own sections." & @CRLF & _
"" & @CRLF & _
"{% comment %} " & @CRLF & _
"### <a id="Example_New_Feature"></a> Example New Feature ###" & @CRLF & _
"" & @CRLF & _
"This is a short description of the new feature. Group two or more closely related features using a common section with h4 subsections. Link to associated documentation as shown below (based on the number of links)." & @CRLF & _
"" & @CRLF & _
"See also: [Associated Documentation](Associated_Documentation.md)" & @CRLF & _
"" & @CRLF & _
"See also: [Associated Documentation](Associated_Documentation.md) and [Associated Documentation](Associated_Documentation.md)" & @CRLF & _
"" & @CRLF & _
"See also: [Associated Documentation](Associated_Documentation.md), [Associated Documentation](Associated_Documentation.md), and [Associated Documentation](Associated_Documentation.md)" & @CRLF & _
"{% endcomment %}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## <a id="User_Interfaces"></a> User Interfaces ##" & @CRLF & _
"" & @CRLF & _
"This section describes new features for user interfaces, including Tempo, sites, and embedded interfaces." & @CRLF & _
"" & @CRLF & _
"### Sites Revolution ###" & @CRLF & _
"" & @CRLF & _
"#### <a id="Tempo_Reports_in_Sites"></a> Tempo Reports in Sites ###" & @CRLF & _
"" & @CRLF & _
"In addition to task reports, actions and record types, designers can now configure sites to have Tempo reports. Making it easier for sites only users to view and analyze data." & @CRLF & _
"" & @CRLF & _
"<img class="screenshot" src="images/release_notes/SitesTempoReports.png"/>" & @CRLF & _
"" & @CRLF & _
"[configure sites with reports](Sites.md#Configure_a_Site_Page)." & @CRLF & _
"" & @CRLF & _
"#### <a id="Inline_Task_Management"></a> Inline Task Management ###" & @CRLF & _
"" & @CRLF & _
"Task management has improved for users of all Appian user environments. All task management controls for SAIL [tasks](Tasks.md), including save changes, reassign, and reject, have been moved to above the task form." & @CRLF & _
"" & @CRLF & _
"The left-hand navigation bar no longer appears in Tempo when viewing SAIL tasks, allowing task forms to occupy the full page width." & @CRLF & _
"" & @CRLF & _
"These task management controls are now available to [sites](Sites.md) users for the first time." & @CRLF & _
"" & @CRLF & _
"Users of [embedded](Embedded_Interfaces.md) tasks now have the option to save changes to SAIL tasks." & @CRLF & _
"" & @CRLF & _
"<img src="images/release_notes/InlineTaskControls.png" class="screenshot"/>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#### <a id="User_Record_in_Sites"></a> User Record in Sites ###" & @CRLF & _
"" & @CRLF & _
"We have made it possible for designers to configure the User record and User record links in sites." & @CRLF & _
"" & @CRLF & _
"<img class="screenshot" src="images/release_notes/SitesUserRecord.png"/>" & @CRLF & _
"" & @CRLF & _
"#### <a id="User_Profile_in_Sites"></a> User Profile in Sites ###" & @CRLF & _
"" & @CRLF & _
"Users can now update their profiles in a site by clicking on their avatar in the header and clicking on the Profile button. " & @CRLF & _
"" & @CRLF & _
"<img class="screenshot" src="images/release_notes/SitesUserProfile.png"/>" & @CRLF & _
"" & @CRLF & _
"#### Wider Sites ###" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")