#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\s*[a-zA-Z]{1}[0-9a-zA-Z][0-9a-zA-Z '-.=#/]*$"
Local $sString = "test=123" & @CRLF & _
"=test123" & @CRLF & _
"austin .,#/-" & @CRLF & _
"Aberdeen" & @CRLF & _
"Abilene" & @CRLF & _
"Akron" & @CRLF & _
"Albany" & @CRLF & _
"Albu querque" & @CRLF & _
"Alexandria" & @CRLF & _
"Allentown" & @CRLF & _
"Amarillo" & @CRLF & _
"Anaheim" & @CRLF & _
"Anchorage" & @CRLF & _
"Ann Arbor" & @CRLF & _
"Antioch" & @CRLF & _
"Apple Valley" & @CRLF & _
"Appleton" & @CRLF & _
"Arlington" & @CRLF & _
"Arvada" & @CRLF & _
"Asheville" & @CRLF & _
"Athens" & @CRLF & _
"Atlanta" & @CRLF & _
"Atlantic City" & @CRLF & _
"Augusta" & @CRLF & _
"Aurora" & @CRLF & _
"Austin" & @CRLF & _
"Bakersfield" & @CRLF & _
"Baltimore" & @CRLF & _
"Barnstable" & @CRLF & _
"Baton Rouge" & @CRLF & _
"Beaumont" & @CRLF & _
"Bel Air" & @CRLF & _
"Bellevue" & @CRLF & _
"Berkeley" & @CRLF & _
"Bethlehem" & @CRLF & _
"Billings" & @CRLF & _
"Birmingham" & @CRLF & _
"Bloomington" & @CRLF & _
"Boise" & @CRLF & _
"Boise City" & @CRLF & _
"Bonita Springs" & @CRLF & _
"Boston" & @CRLF & _
"Boulder" & @CRLF & _
"Bradenton" & @CRLF & _
"Bremerton" & @CRLF & _
"Bridgeport" & @CRLF & _
"Brighton" & @CRLF & _
"Brownsville" & @CRLF & _
"Bryan" & @CRLF & _
"Buffalo" & @CRLF & _
"Burbank" & @CRLF & _
"Burlington" & @CRLF & _
"Cambridge" & @CRLF & _
"Canton" & @CRLF & _
"Cape Coral" & @CRLF & _
"Carrollton" & @CRLF & _
"Cary" & @CRLF & _
"Cathedral City" & @CRLF & _
"Cedar Rapids" & @CRLF & _
"Champaign" & @CRLF & _
"Chandler" & @CRLF & _
"Charleston" & @CRLF & _
"Charlotte" & @CRLF & _
"Chattanooga" & @CRLF & _
"Chesapeake" & @CRLF & _
"Chicago" & @CRLF & _
"Chula Vista" & @CRLF & _
"Cincinnati" & @CRLF & _
"Clarke County" & @CRLF & _
"Clarksville" & @CRLF & _
"Clearwater" & @CRLF & _
"Cleveland" & @CRLF & _
"College Station" & @CRLF & _
"Colorado Springs" & @CRLF & _
"Columbia" & @CRLF & _
"Columbus" & @CRLF & _
"Concord" & @CRLF & _
"Coral Springs" & @CRLF & _
"Corona" & @CRLF & _
"Corpus Christi" & @CRLF & _
"Costa Mesa" & @CRLF & _
"Dallas" & @CRLF & _
"Daly City" & @CRLF & _
"Danbury" & @CRLF & _
"Davenport" & @CRLF & _
"Davidson County" & @CRLF & _
"Dayton" & @CRLF & _
"Daytona Beach" & @CRLF & _
"Deltona" & @CRLF & _
"Denton" & @CRLF & _
"Denver" & @CRLF & _
"Des Moines" & @CRLF & _
"Detroit" & @CRLF & _
"Downey" & @CRLF & _
"Duluth" & @CRLF & _
"Durham" & @CRLF & _
"El Monte" & @CRLF & _
"El Paso" & @CRLF & _
"Elizabeth" & @CRLF & _
"Elk Grove" & @CRLF & _
"Elkhart" & @CRLF & _
"Erie" & @CRLF & _
"Escondido" & @CRLF & _
"Eugene" & @CRLF & _
"Evansville" & @CRLF & _
"Fairfield" & @CRLF & _
"Fargo" & @CRLF & _
"Fayetteville" & @CRLF & _
"Fitchburg" & @CRLF & _
"Flint" & @CRLF & _
"Fontana" & @CRLF & _
"Fort Collins" & @CRLF & _
"Fort Lauderdale" & @CRLF & _
"Fort Smith" & @CRLF & _
"Fort Walton Beach" & @CRLF & _
"Fort Wayne" & @CRLF & _
"Fort Worth" & @CRLF & _
"Frederick" & @CRLF & _
"Fremont" & @CRLF & _
"Fresno" & @CRLF & _
"Fullerton" & @CRLF & _
"Gainesville" & @CRLF & _
"9Garden Grove" & @CRLF & _
"Garland" & @CRLF & _
"Gastonia" & @CRLF & _
"Gilbert" & @CRLF & _
"Glendale" & @CRLF & _
"Grand Prairie" & @CRLF & _
"Grand Rapids" & @CRLF & _
"Grayslake" & @CRLF & _
"Green Bay" & @CRLF & _
"GreenBay" & @CRLF & _
"Greensboro" & @CRLF & _
"Greenville" & @CRLF & _
"Gulfport-Biloxi" & @CRLF & _
"Hagerstown" & @CRLF & _
"Hampton" & @CRLF & _
"Harlingen" & @CRLF & _
"Harrisburg" & @CRLF & _
"Hartford" & @CRLF & _
"Havre de Grace" & @CRLF & _
"Hayward" & @CRLF & _
"Hemet" & @CRLF & _
"Henderson" & @CRLF & _
"Hesperia" & @CRLF & _
"Hialeah" & @CRLF & _
"Hickory" & @CRLF & _
"High Point" & @CRLF & _
"Hollywood" & @CRLF & _
"Honolulu" & @CRLF & _
"Houma" & @CRLF & _
"Houston" & @CRLF & _
"Howell" & @CRLF & _
"Huntington" & @CRLF & _
"Huntington Beach" & @CRLF & _
"Huntsville" & @CRLF & _
"Independence" & @CRLF & _
"Indianapolis" & @CRLF & _
"Inglewood" & @CRLF & _
"Irvine" & @CRLF & _
"Irving" & @CRLF & _
"Jackson" & @CRLF & _
"Jacksonville" & @CRLF & _
"Jefferson" & @CRLF & _
"Jersey City" & @CRLF & _
"Johnson City" & @CRLF & _
"Joliet" & @CRLF & _
"Kailua" & @CRLF & _
"Kalamazoo" & @CRLF & _
"Kaneohe" & @CRLF & _
"Kansas City" & @CRLF & _
"Kennewick" & @CRLF & _
"Kenosha" & @CRLF & _
"Killeen" & @CRLF & _
"Kissimmee" & @CRLF & _
"Knoxville" & @CRLF & _
"Lacey" & @CRLF & _
"Lafayette" & @CRLF & _
"Lake Charles" & @CRLF & _
"Lakeland" & @CRLF & _
"Lakewood" & @CRLF & _
"Lancaster" & @CRLF & _
"Lansing" & @CRLF & _
"Laredo" & @CRLF & _
"Las Cruces" & @CRLF & _
"Las Vegas" & @CRLF & _
"Layton" & @CRLF & _
"Leominster" & @CRLF & _
"Lewisville" & @CRLF & _
"Lexington" & @CRLF & _
"Lincoln" & @CRLF & _
"Little Rock" & @CRLF & _
"Long Beach" & @CRLF & _
"Lorain" & @CRLF & _
"Los Angeles" & @CRLF & _
"Louisville" & @CRLF & _
"Lowell" & @CRLF & _
"Lubbock" & @CRLF & _
"Macon" & @CRLF & _
"Madison" & @CRLF & _
"Manchester" & @CRLF & _
"Marina" & @CRLF & _
"Marysville" & @CRLF & _
"McAllen" & @CRLF & _
"McHenry" & @CRLF & _
"Medford" & @CRLF & _
"Melbourne" & @CRLF & _
"Memphis" & @CRLF & _
"Merced" & @CRLF & _
"Mesa" & @CRLF & _
"Mesquite" & @CRLF & _
"Miami" & @CRLF & _
"Milwaukee" & @CRLF & _
"Minneapolis" & @CRLF & _
"Miramar" & @CRLF & _
"Mission Viejo" & @CRLF & _
"Mobile" & @CRLF & _
"Modesto" & @CRLF & _
"Monroe" & @CRLF & _
"Monterey" & @CRLF & _
"Montgomery" & @CRLF & _
"Moreno Valley" & @CRLF & _
"Murfreesboro" & @CRLF & _
"Murrieta" & @CRLF & _
"Muskegon" & @CRLF & _
"Myrtle Beach" & @CRLF & _
"Naperville" & @CRLF & _
"Naples" & @CRLF & _
"Nashua" & @CRLF & _
"Nashville" & @CRLF & _
"New Bedford" & @CRLF & _
"New Haven" & @CRLF & _
"New London" & @CRLF & _
"New Orleans" & @CRLF & _
"New York" & @CRLF & _
"New York City" & @CRLF & _
"Newark" & @CRLF & _
"Newburgh" & @CRLF & _
"Newport News" & @CRLF & _
"Norfolk" & @CRLF & _
"Normal" & @CRLF & _
"Norman" & @CRLF & _
"North Charleston" & @CRLF & _
"North Las Vegas" & @CRLF & _
"North Port" & @CRLF & _
"Norwalk" & @CRLF & _
"Norwich" & @CRLF & _
"Oakland" & @CRLF & _
"Ocala" & @CRLF & _
"Oceanside" & @CRLF & _
"Odessa" & @CRLF & _
"Ogden" & @CRLF & _
"Oklahoma City" & @CRLF & _
"Olathe" & @CRLF & _
"Olympia" & @CRLF & _
"Omaha" & @CRLF & _
"Ontario" & @CRLF & _
"Orange" & @CRLF & _
"Orem" & @CRLF & _
"Orlando" & @CRLF & _
"Overland Park" & @CRLF & _
"Oxnard" & @CRLF & _
"Palm Bay" & @CRLF & _
"Palm Springs" & @CRLF & _
"Palmdale" & @CRLF & _
"Panama City" & @CRLF & _
"Pasadena" & @CRLF & _
"Paterson" & @CRLF & _
"Pembroke Pines" & @CRLF & _
"Pensacola" & @CRLF & _
"Peoria" & @CRLF & _
"Philadelphia" & @CRLF & _
"Phoenix" & @CRLF & _
"Pittsburgh" & @CRLF & _
"Plano" & @CRLF & _
"Pomona" & @CRLF & _
"Pompano Beach" & @CRLF & _
"Port Arthur" & @CRLF & _
"Port Orange" & @CRLF & _
"Port Saint Lucie" & @CRLF & _
"Port St. Lucie" & @CRLF & _
"Portland" & @CRLF & _
"Portsmouth" & @CRLF & _
"Poughkeepsie" & @CRLF & _
"Providence" & @CRLF & _
"Provo" & @CRLF & _
"Pueblo" & @CRLF & _
"Punta Gorda" & @CRLF & _
"Racine" & @CRLF & _
"Raleigh" & @CRLF & _
"Rancho Cucamonga" & @CRLF & _
"Reading" & @CRLF & _
"Redding" & @CRLF & _
"Reno" & @CRLF & _
"Richland" & @CRLF & _
"Richmond" & @CRLF & _
"Richmond County" & @CRLF & _
"Riverside" & @CRLF & _
"Roanoke" & @CRLF & _
"Rochester" & @CRLF & _
"Rockford" & @CRLF & _
"Roseville" & @CRLF & _
"Round Lake Beach" & @CRLF & _
"Sacramento" & @CRLF & _
"Saginaw" & @CRLF & _
"Saint Louis" & @CRLF & _
"Saint Paul" & @CRLF & _
"Saint Petersburg" & @CRLF & _
"Salem" & @CRLF & _
"Salinas" & @CRLF & _
"Salt Lake City" & @CRLF & _
"San Antonio" & @CRLF & _
"San Bernardino" & @CRLF & _
"San Buenaventura" & @CRLF & _
"San Diego" & @CRLF & _
"San Francisco" & @CRLF & _
"San Jose" & @CRLF & _
"Santa Ana" & @CRLF & _
"Santa Barbara" & @CRLF & _
"Santa Clara" & @CRLF & _
"Santa Clarita" & @CRLF & _
"Santa Cruz" & @CRLF & _
"Santa Maria" & @CRLF & _
"Santa Rosa" & @CRLF & _
"Sarasota" & @CRLF & _
"Savannah" & @CRLF & _
"Scottsdale" & @CRLF & _
"Scranton" & @CRLF & _
"Seaside" & @CRLF & _
"Seattle" & @CRLF & _
"Sebastian" & @CRLF & _
"Shreveport" & @CRLF & _
"Simi Valley" & @CRLF & _
"Sioux City" & @CRLF & _
"Sioux Falls" & @CRLF & _
"South Bend" & @CRLF & _
"South Lyon" & @CRLF & _
"Spartanburg" & @CRLF & _
"Spokane" & @CRLF & _
"Springdale" & @CRLF & _
"Springfield" & @CRLF & _
"St. Louis" & @CRLF & _
"St. Paul" & @CRLF & _
"St. Petersburg" & @CRLF & _
"Stamford" & @CRLF & _
"Sterling Heights" & @CRLF & _
"Stockton" & @CRLF & _
"Sunnyvale" & @CRLF & _
"Syracuse" & @CRLF & _
"Tacoma" & @CRLF & _
"Tallahassee" & @CRLF & _
"Tampa" & @CRLF & _
"Temecula" & @CRLF & _
"Tempe" & @CRLF & _
"Thornton" & @CRLF & _
"Thousand Oaks" & @CRLF & _
"Toledo" & @CRLF & _
"Topeka" & @CRLF & _
"Torrance" & @CRLF & _
"Trenton" & @CRLF & _
"Tucson" & @CRLF & _
"Tulsa" & @CRLF & _
"Tuscaloosa" & @CRLF & _
"Tyler" & @CRLF & _
"Utica" & @CRLF & _
"Vallejo" & @CRLF & _
"Vancouver" & @CRLF & _
"Vero Beach" & @CRLF & _
"Victorville" & @CRLF & _
"Virginia Beach" & @CRLF & _
"Visalia" & @CRLF & _
"Waco" & @CRLF & _
"Warren" & @CRLF & _
"Washington" & @CRLF & _
"Waterbury" & @CRLF & _
"Waterloo" & @CRLF & _
"West Covina" & @CRLF & _
"West Valley City" & @CRLF & _
"Westminster" & @CRLF & _
"Wichita" & @CRLF & _
"Wilmington" & @CRLF & _
"Winston" & @CRLF & _
"Winter Haven" & @CRLF & _
"Worcester" & @CRLF & _
"Yakima" & @CRLF & _
"Yonkers" & @CRLF & _
"York" & @CRLF & _
"Youngstown"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")