package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{4}-\d{4}$`)
var str = `2010-1000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}