#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi){#include\s*([\w.]+)\s*}"
Local $sString = "{#include header.html}" & @CRLF & _
" <header class="bg-gradient-to-r from-purple-700 to-indigo-800 shadow-lg w-full">" & @CRLF & _
" <div class="max-w mx-auto px-4 sm:px-6 lg:px-8 py-6">" & @CRLF & _
" <div class="flex flex-col items-center justify-between md:flex-row">" & @CRLF & _
" <a href="/">" & @CRLF & _
" <h1 class="mb-4 text-2xl font-bold text-white md:mb-0 md:text-3xl">Header</h1>" & @CRLF & _
" </a>" & @CRLF & _
" <nav class="flex space-x-4">" & @CRLF & _
" <a href="/">" & @CRLF & _
" <a href="#" class="text-white transition duration-150 ease-in-out hover:text-purple-200">Home</a>" & @CRLF & _
" </a>" & @CRLF & _
" <a href="#" class="text-white transition duration-150 ease-in-out hover:text-purple-200">About</a>" & @CRLF & _
" <a href="#" class="text-white transition duration-150 ease-in-out hover:text-purple-200">Contact</a>" & @CRLF & _
" </nav>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </header>" & @CRLF & _
"" & @CRLF & _
" <div class="flex flex-grow">" & @CRLF & _
" <aside class="w-72 bg-gray-100 scrollable-column">" & @CRLF & _
" <div class="p-6">" & @CRLF & _
" <h2 class="mb-4 text-xl font-semibold text-gray-800">Directories</h2>" & @CRLF & _
" {#each item in dirs}" & @CRLF & _
" <div class="mb-3">" & @CRLF & _
" <a href="{item.link}"" & @CRLF & _
" class="font-medium text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800">{item.name}</a>" & @CRLF & _
" </div>" & @CRLF & _
" {/each}" & @CRLF & _
" </div>" & @CRLF & _
" </aside>" & @CRLF & _
"" & @CRLF & _
" <main class="flex-grow bg-white scrollable-column">" & @CRLF & _
" <div class="p-6 md:p-8">" & @CRLF & _
" {#each item in files}" & @CRLF & _
" <div class="space-y-4">" & @CRLF & _
" <div class="flex flex-col sm:flex-row border-b-2 border-gray-200 pb-4">" & @CRLF & _
" <div class="w-full sm:w-[150px] h-[150px] border-2 border-black flex items-center justify-center overflow-hidden mb-4 sm:mb-0 flex-shrink-0">" & @CRLF & _
" <a href="{item.link}">" & @CRLF & _
" <img src="{item.image}" alt="thumbnail" class="w-full h-full object-cover">" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="flex-grow pt-2 sm:pl-4">" & @CRLF & _
" <h3 class="mb-2 text-xl font-semibold">" & @CRLF & _
" <a href="{item.link}"" & @CRLF & _
" class="text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800">{item.name}</a>" & @CRLF & _
" </h3>" & @CRLF & _
" <p class="text-black text-sm -mt-2 mb-2">{item.date}</p>" & @CRLF & _
" <p class="text-gray-600 text-lg">{item.summery}</p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" {/each}" & @CRLF & _
" </div>" & @CRLF & _
" </main>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <footer class="bg-gray-800 text-white">" & @CRLF & _
" <div class="container mx-auto px-4 py-8">" & @CRLF & _
" <div class="flex flex-col items-center justify-between md:flex-row">" & @CRLF & _
" <div class="mb-4 text-2xl font-semibold md:mb-0">Footer</div>" & @CRLF & _
" <div class="flex space-x-4">" & @CRLF & _
" <a href="#" class="transition duration-150 ease-in-out hover:text-purple-300">Privacy</a>" & @CRLF & _
" <a href="#" class="transition duration-150 ease-in-out hover:text-purple-300">Terms</a>" & @CRLF & _
" <a href="#" class="transition duration-150 ease-in-out hover:text-purple-300">Contact</a>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </footer>" & @CRLF & _
"{#include footer.html}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")