$re = '/[0-9]\ (Ki[A-Za-z]*)$/i';
$str = '24159 Kiel';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);