package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(P)\s`)
var str = `PCEB
P
P and k`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}