$re = '/@([0-9\.]+),([0-9\.]+),([0-9z]+)/';
$str = 'https://www.google.fr/maps/place/Avenue+du+G%C3%A9n%C3%A9ral+Leclerc,+Vand%C5%93uvre-l%C3%A8s-Nancy/@48.6602046,6.1612375,17z/data=!4m2!3m1!1s0x47949883998f2a0d:0xb3a20a525afff3a8
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);