$re = '/Select +(.+);/m';
$str = ' Select ob.name;';
$subst = "switch ($1)\{";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;