const regex = new RegExp('yourtext(?=(?:[^\\'\\"]*(?:\\'|\\")[^\\'\\"]*(?:\\'|\\"))*[^\\'\\"]*$)', 'gm')
const str = `sada yourtext 'yourtext ' "yourtext uud" yourtext`;
const subst = `-------`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);