import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\W)(?:youtube(?:-nocookie)?\\.com/(?:.*[?&]v=|v/|e(?:mbed)?/|[^/]+/.+/)|youtu\\.be/)([\\w-]+)";
final String string = "youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "https://youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=feedrec_grec_index\n"
+ "https://www.youtube.com/watch?v=DFYRQ_zQ-gk#t=0m10s\n"
+ "https://www.youtube.com/?feature=player_embedded&v=DFYRQ_zQ-gk\n"
+ "https://www.youtube.com/watch?feature=player_embedded&v=DFYRQ_zQ-gk\n"
+ "https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw?v=DFYRQ_zQ-gk#t=0m10s\n\n"
+ "https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0\n"
+ "https://www.youtube.com/e/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0\n"
+ "https://www.youtube.com/embed/DFYRQ_zQ-gk?rel=0\n"
+ "https://www.youtube.com/user/UCucW7UIJh8FHbv2O0jW8skw#p/u/11/DFYRQ_zQ-gk?rel=0\n"
+ "https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw#p/c/54B8C800269D7C1B/0/DFYRQ_zQ-gk?rel=0\n\n"
+ "m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "//m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
+ "https://m.youtube.com/watch?v=DFYRQ_zQ-gk\n\n"
+ "youtu.be/DFYRQ_zQ-gk\n"
+ "https://youtu.be/DFYRQ_zQ-gk\n"
+ "https://youtu.be/DFYRQ_zQ-gk?t=2s\n"
+ "https://youtu.be/DFYRQ_zQ-gk?list=PLelYX5BVrtO0sWvnTSdvot21pjlKTNVeU\n\n"
+ "https://youtube-nocookie.com/watch?v=DFYRQ_zQ-gk?t=2s\n\n"
+ "<iframe width=\"480\" height=\"270\" src=\"https://www.youtube.com/embed/DFYRQ_zQ-gk?feature=oembed\" frameborder=\"0\" allow=\"accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>\n\n"
+ "in text youtube.com/watch?v=DFYRQ_zQ-gk in text\n\n"
+ "DFYRQ_zQ-gk\n"
+ "/watch?v=DFYRQ_zQ-gk\n"
+ "https://www.youtubee.com/watch?v=DFYRQ_zQ-gk\n"
+ "https://notyoutube.com/watch?v=DFYRQ_zQ-gk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}