import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*-.*(?P<sig>[a-zA-Z]{2})";
final String string = "VIP MANAUS, Endereço: R. VISCONDE DE SINIMBU, 1568, Bairro: PQ. LARANJEIRAS, Manaus - AM\n\n"
+ "VIP PORTO VELHO, Endereço: AV. RIO MADEIRA Nº 612, Bairro: LAGOA, PORTO VELHO -RO\n\n"
+ "VIP BELÉM ALÇA VIARIA, Endereço: KM 01, Bairro: CENTRO, Marituba-pa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}