re = /^(([^<>()[\]\\.,;:\s@\"]]+(\.[^<>()[\]\\.,;:\s@\"]]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/m
str = 'aslam@gmail.cmm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end