const regex = new RegExp('(ประเทศ)|(อเมริกา|เกาหลีใต้|เกาหลีเหนือ|ฝรั่งเศส|อิตาลี)|ประเทศ.*', 'gm')
const str = `ประเทศอเมริกาเป็นประเทศที่ดี
ประเทศเกาหลีใต้เป็นประเทศที่ดี
เกาหลีใต้คือประเทศ
ประเทศเกาหลีเหนือคือประเทศสวยงาม
ประเทศญี่ปุ่น
ประเทศอเมรกาเป็นประเทศที่ดี
เมืองที่สวยงามคือประเทศที่ดีงามอย่างฝรั่งเศสแต่ก็ไม่ได้มากไปกว่าอิตาลีที่เป็นประเทศประเทศหนึ่งเหมือนกัน
ประเทศรักสงบ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}