package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.[^.\/]++$`)
var str = `fsdfsdf.sdfsdf/fsdfsd.fsdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}