import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<email>(?P<local>(?![\\.\\ ]+)(?=[^@]+)(?:(?:(?:[\\#\\!\\$\\%\\&\\'\\*\\+\\-\\/\\=\\?\\^\\_\\`\\{\\|\\}\\~\\p{L}\\p{N}])*(?:(?<=\\.|^)(?:\\\"(?:[^\\\"]|(?<=\\\\)[\\\"\\(\\)\\,\\:\\;\\<\\>\\@\\[\\\\\\]])*\\\")\\.?)*(?:[\\#\\!\\$\\%\\&\\'\\*\\+\\-\\/\\=\\?\\^\\_\\`\\{\\|\\}\\~\\p{L}\\p{N}])*)))(?<!\\.)\\@(?P<host>(?:[\\w\\-]+?\\.?)*|\\[[\\w\\d\\:]*\\])(?![\\.\\ ]+))$";
final String string = "EMAIL\n"
+ "________\n"
+ "john.smith(comment)@example.com\n"
+ "(comment)john.smith@example.com\n"
+ "john.smith@(comment)example.com\n"
+ "john.smith@example.com(comment)\n"
+ "abc.\"defghi\".xyz@example.com\n"
+ "\"abcdefghixyz\"@example.com\n"
+ "\"John..Doe\"@example.com\n"
+ "\"test\".\"test\"@test.com\n"
+ "test.\"test\"@test.com\n"
+ "\"test\".test@test.com\n"
+ "\"\\\"\"@test.com\n"
+ "\"\\\"\\\"\".test@test.com\n"
+ "prettyandsimple@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-dash@example.com\n"
+ "x@example.com\n"
+ "\"much.more unusual\"@example.com\n"
+ "\"very.unusual.@.unusual.com\"@example.com\n"
+ "\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
+ "example-indeed@strange-example.com\n"
+ "admin@mailserver1\n"
+ "#!$%&'*+-/=?^_`{}|~@example.org\n"
+ "\"()<>[]:,;@\\\\\\\"!#$%&'-/=?^_`{}| ~.a\"@example.org\n"
+ "\" \"@example.org\n"
+ "example@localhost\n"
+ "example@s.solutions\n"
+ "user@localserver\n"
+ "user@tt\n"
+ "user@[IPv6:2001:DB8::1]\n"
+ "________\n"
+ "@test.com\n"
+ "abc\\\"def\\\"ghi@example.com\n"
+ "abc\"defghi\"xyz@example.com\n"
+ "John..Doe@example.com\n"
+ "Abc.example.com\n"
+ "A@b@c@example.com\n"
+ "\"\\\"\"\".\"\"@test.com\n"
+ "test\"@test.com\n"
+ ".\"\".@test.com\n"
+ "a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
+ "just\"not\"right@example.com\n"
+ "this is\"not\\allowed@example.com\n"
+ "this\\ still\\\"not\\\\allowed@example.com\n"
+ "john..doe@example.com\n"
+ "john.doe@example..com.somethingelse.something.more..more\n"
+ " john.doe@example.com\n"
+ "john.doe@example.com \n"
+ ".john.doe@something.com\n"
+ "johndoe.@something.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}