$re = '/\b((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4}\b/m';
$str = '122.16.465.5
11.255.255.0
95.55.17.8
1.1.1.1
127.0.0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);