package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:\+7|8)?9(?:\d{9})$`)
var str = `89200760939`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}