package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+\s*\(\s*\w+\s*=\s*\w+\s*\)$`)
var str = `word(a=b)
word ( a != b )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}