import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^) # Start of string or word boundary\n"
+ "( # Capture Group\n"
+ "(?: # Non-Capture Group for X.\n"
+ "(?: # Nested NCG for 0..255\n"
+ "(?:\\d){1,2}| # Allow any single digit or any pair of digits or\n"
+ "(?:1\\d{2})| # 3 Digits starting with 1 or\n"
+ "(?:2[0-4]\\d)| # 3 Digists starting with 20..24 or\n"
+ "(?:25[0-5]) # 250..255\n"
+ ") # this should allow X=0..255 in the NCG\n"
+ "\\. # Must be followed by a literal .\n"
+ "){3} # X. Must repeat exactly 3 times\n"
+ "(?: # NCG for final 0..255\n"
+ "(?:\\d{1,2})| # Allow any single digit or any pair of digits or\n"
+ "(?:1\\d{2})| # 3 Digits starting with 1 or\n"
+ "(?:2[0-4]\\d)| # 3 digits starting 20..24 or\n"
+ "(?:25[0-5]) # 250.255\n"
+ ") # End of final 0.255\n"
+ ") # End of capture group\n"
+ "(?:\\s|$) # Must be followed by EOS or wspace";
final String string = "123.123.123.145 is an IP4 so is 1.2.3.4 and 1.22.33.44 but 256.1.2.3 isn't 254.1.2.3 is but 260.1.1.1 isn't nor 2.5.256.1 and 1.2.3.4:222 IP6 1.2.3.4.5.6";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}