import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((NA?TU?RE?S?\\s?OWN\\b)|(NAT\\s?\\.?OWN\\b)|(N\\s?\\W?\\.?O\\.?\\b)|(N\\.\\sOWN\\b)|(NATURE\\W?S\\b)|(NATURE\\sO\\b))";
final String string = "N O 100% WHOLE WHEAT\n"
+ "N O BUTTER BREAD\n"
+ "N O HONEY WHT\n"
+ "N O LIGHT HONEY\n"
+ "N O LIGHT WHEAT\n"
+ "N O WHITE WHEAT HAMS\n"
+ "N O WHITE WHEAT HOTDOGS\n"
+ "N. OWN HONEY WHEAT BUN\n"
+ "N.O 6CT 100% WHOLE\n"
+ "N.O 6CT MULTI GRAIN\n"
+ "N.O. 100% W WHEAT\n"
+ "N.O. 100% W WHEAT\n"
+ "N.O. HEALTHY\n"
+ "N.O. Original Bagel 20 OZ\n"
+ "N.O. WHITE WHEAT\n"
+ "N.O.ALL NATURAL 12 GRAIN\n"
+ "N.O.ALL NATURAL WH WHT\n"
+ "N/O BUTTER HAMBURGER BUN\n"
+ "N/O DOUBLE FIBER WHEAT\n"
+ "NAT OWN BTR HOT DOG BUNS\n"
+ "NAT OWN CIN RAISIN\n"
+ "NAT OWN ENG MUF\n"
+ "NAT OWN HNY WHT HD BUNS\n"
+ "NAT.OWN ORG HONEY WHEAT\n"
+ "NATURE O BREAD 100% WHL WHEAT W/ HONEY 16 OZ\n"
+ "NATURES 16 OZ SGRFR WHOL GRN\n"
+ "NATURE'S 2/20Z 100% WHEAT BRD\n"
+ "NATURE'S 2/20Z 100% WHEAT BRD\n"
+ "NATURE'S 2/20Z BUTTER BREAD\n"
+ "NATURE'S 2/20Z BUTTER BREAD\n"
+ "NATURE'S 2/20Z HONEY WHEAT\n"
+ "NATURE'S 2/20Z HONEY WHEAT\n"
+ "NATURE'S 24 OZ DOUBLE FIBER\n"
+ "NATURES OWN BUTTER ROLLS\n"
+ "NATURES OWN CINNAMON RAIS\n"
+ "NATURES OWN HONEY WHEAT THIN 20 OZ \n"
+ "NATURES OWN HONY 7 GRAIN\n"
+ "NATURES OWN LIFE 7 GRAINS\n"
+ "NATURES OWN LIFE WHEAT & PROTEIN BREAD\n"
+ "NO 100% W G WHEAT BREAD\n"
+ "NO 100% WHL GRN OVAL\n"
+ "NO ALL NAT HNY WHT BRY\n"
+ "NO SGR FRE WHOLE GRAIN\n"
+ "NO WHITE/WHEAT ROUND TOP\n"
+ "NTRS OWN HNY OAT SOFT\n"
+ "NTRS OWN HOTS NTRS OWN HOTS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}