#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((1\s?)?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$"
Local $sString = "555-555-5555" & @CRLF & _
"(555)555-5555" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"555 555 5555" & @CRLF & _
"5555555555" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"1 456 789 4444" & @CRLF & _
"//fail" & @CRLF & _
"//" & @CRLF & _
"1(555)555-5555" & @CRLF & _
"1 555)555-5555" & @CRLF & _
"123**&!!asdf#" & @CRLF & _
"55555555" & @CRLF & _
"(6505552368)" & @CRLF & _
"2 (757) 622-7382" & @CRLF & _
"0 (757) 622-7382" & @CRLF & _
"-1 (757) 622-7382" & @CRLF & _
"2 757 622-7382" & @CRLF & _
"10 (757) 622-7382" & @CRLF & _
"27576227382" & @CRLF & _
"(275)76227382" & @CRLF & _
"2(757)6227382" & @CRLF & _
"2(757)622-7382" & @CRLF & _
"555)-555-5555" & @CRLF & _
"(555-555-5555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")