const regex = /(\d+\.\d+\.\d+\.\d+)\s+([\w\-]+)\s+([\w\-]+)\s+(\w+)\s+(\d+)\s+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+([\\w\\-]+)\\s+([\\w\\-]+)\\s+(\\w+)\\s+(\\d+)\\s+', '')
const str = `####################################################################################
# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <Port>
####################################################################################
#192.168.122.225 database database 1024M
#192.168.122.226 database database 1024M
192.168.122.253 database database 1024M
## MCng BackEnd ServicesG
#192.168.122.125 amqs activemq 1024M
#
# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <JMXPort> <WebPort> #
#
192.168.122.125 csm csm 2048M 12000
192.168.122.125 clog clog 1024M 12001
192.168.122.146 sec
192.168.122.105 dtu-ds dtu-ds01 4096M 12004 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}