re = /(?<!\d)(?:(?:[01]?\d\d?|2[0-4]\d|25[0-5])\.){3}(?:[01]?\d\d?|2[0-4]\d|25[0-5])(?!\d)/m
str = '012.33.4.5
12.34.45.67
120.20.23.56
1.2.3.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end