import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<(\\w+)(?:\\s*\\>|\\s*\\/\\>)?";
final String string = "\n"
+ "<!DOCTYPE html>\n"
+ "<html lang=\"el\" dir=\"ltr\" class=\"no-js\">\n"
+ "<head >\n"
+ " <meta charset=\"utf-8\" />\n"
+ " <title>Radial</title>\n"
+ " <meta name=\"description\" content=\"Η Radial σχεδιάζει και αναπτÏσσει websites, οÏγανώνει online καμπάνιες και δημιουÏγεί εταιÏικÎÏ‚ ταυτότητες.\" />\n"
+ " \n"
+ " <meta property=\"fb:page_id\" content=\"118981334805256\" />\n"
+ " <meta property=\"fb:app_id\" content=\"166019300145537\" />\n"
+ " \n"
+ " \n"
+ " <!--[if lt IE 9]><script type=\"text/javascript\" src=\"http://html5shiv.googlecode.com/svn/trunk/html5.js\"></script><![endif]-->\n"
+ " <script type=\"text/javascript\">(function(H){H.className=H.className.replace(/\\bno-js\\b/,'js')})(document.documentElement);</script>\n"
+ " \n"
+ " <link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"http://static.radial.gr/styles/screen.css?43614\" />\n"
+ " \n"
+ " <script type=\"text/javascript\" src=\"http://use.typekit.com/ioa2dxy.js\"></script>\n"
+ " <script type=\"text/javascript\">try{Typekit.load();}catch(e){}</script?\n"
+ " \n"
+ " <link rel=\"alternate\" type=\"application/rss+xml\" title=\"Τελευταία ÎÏγα\" href=\"/feed/\" />\n"
+ " \n"
+ " \n"
+ " \n"
+ "</head>\n\n"
+ "<body id=\"home\" class=\"\">\n\n"
+ "<header id=\"main-header\"><div class=\"wrapper\">\n"
+ " <div id=\"logo\"><a href=\"/\"><img src=\"http://static.radial.gr/images/radial-logo.png\" alt=\"Radial\" /></a></div>\n"
+ " <nav id=\"main-nav\">\n"
+ " <ul>\n"
+ " <li><a href=\"/projects/\">ΈÏγα</a></li>\n"
+ " <li><a href=\"/profile/\">Î Ïοφίλ</a></li>\n"
+ " <li><a href=\"/contact/\">Επικοινωνία</a></li>\n"
+ " </ul>\n"
+ " </nav>\n"
+ " <nav id=\"lang-nav\">\n"
+ " <span >EΛ</span>\n"
+ " <a href=\"/en/\">EN</a>\n"
+ " </nav>\n\n"
+ "<br />\n\n"
+ "</div></header>\n\n"
+ "<script type=\"text/javascript\">\n"
+ " \n"
+ " var _gaq = _gaq || [];\n"
+ " _gaq.push(['_setAccount', 'UA-515952-44']);\n"
+ " _gaq.push(['_trackPageview']);\n"
+ " (function() {\n"
+ " var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;\n"
+ " ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';\n"
+ " var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);\n"
+ " })();\n\n\n"
+ "</script>\n\n"
+ "</body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}