$re = '/^.*?Name.+?backup01\nKind.+?\nID?\s+:\s([A-Z0-9\-]+)/s';
$str = '====================================================
Name : backup02
Kind : Local
Mount Point : /Volumes/ext_backup01_02
ID : BC51C9FA-DE8A-4BA3-B23E-AEC10E9E9F69
> ==================================================
Name : backup01
Kind : Network
URL : afp://username@server02.local/backup01
Mount Point : /Volumes/backup01
ID : 009B3736-61C5-4996-B9BC-A5230BED7961
====================================================
Name : backup03
Kind : Network
URL : afp://username@server67.local/backup03
Mount Point : /Volumes/backup01
ID : 1E9A3734-33D6-1316-C9B4-B143DA35D9F2
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);