package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[%.*?\%]`)
var str = `docece efeofe [%ciao%] dfe efefk [%edwefdwj%] efejfi dfe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}