re = /(0[1-9]|1[0-9]|2[0-9]|3[01]).(0[1-9]|1[012]).([0-9]{4})( ([0-1]\d|2[0-3])(:[0-5]\d){2}|)/
str = '21.10.2013 13:27:35'
# Print the match result
str.match(re) do |match|
puts match.to_s
end