#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?!<(script|code)[^>]*?>)((\s)(\?|\!|\;|\:))(?![^<]*?<\/(script|code)>)"
Local $sString = "<h2>Déroulement de votre examen radiologique ?</h2>" & @CRLF & _
"<p>test De l’accueil dans nos locaux à la remise des résultats, toute l’équipe Radiolor, médecins radiologues, manipulateurs et secrétaires, reste à votre service et met tout en œuvre pour que votre temps d’attente soit 66 limité et que votre examen se déroule dans les meilleures conditions. Tous les gestes médicaux sont <a>réalisés dans les conditions d’hygiène strictes ; et : dans </a>le respect des bonnes pratiques.</p>" & @CRLF & _
"<p>À votre arrivée , nous vous remercions de passer par le secrétariat et de vous munir de votre ordonnance et de votre carte vitale !.<br />" & @CRLF & _
"N’oubliez pas vos anciens examens et <strong>respectez les consignes</strong> qui vous ont été transmises lors de votre prise de <code>rendez-vous : </code>prise de sang, éventuel produit de contraste ou d’infiltration prescrit ?.</p>" & @CRLF & _
"<!-- meta slider -->" & @CRLF & _
"test" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
"var timer_metaslider_144 = function() {" & @CRLF & _
" var slider = ;!window.jQuery ? window.setTimeout(timer_metaslider_144, 100) : !jQuery.isReady ? window.setTimeout(timer_metaslider_144, 1) : metaslider_144(window.jQuery);" & @CRLF & _
" };" & @CRLF & _
" timer_metaslider_144();" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")