$re = '/^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d]{6,}$/';
$str = 'qWert1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);