import Foundation
let pattern = #"\$\$(?:[^$][^$])*\$\$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Lorem ipsum dolor sit ame $ a = \{ b, c \} $ Lorem 100 \$ ipsum
$$ \left \{
\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array}
\right.
\Leftrightarrow \left \{
\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array}
\right.
$$ Lorem ipsum dolor
$$ \left \{
\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array}
\right.
\Leftrightarrow \left \{
\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array}
\right.
$$ Lorem ipsum dolor
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)