#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)(http:\/\/\s*|https:\/\/\s*|ftp:\/\/\s*)?(www\s*)?(?(1)([.]\s*))?(?(2)([.]\s*))?([a-zA-Z0-9.-]{2,256})(\s*[.]\s*)(ru|pl|kz|by|ua|com|in|pt|br|co.uk)(?![a-zA-Z])([?|#]{1}[=&#a-zA-Z0-9]{2,128})?"
Local $sString = "http:// www . alga-deweloper . pl" & @CRLF & _
"TIRA UM: Ńąm iuvaret tus electram. Tempor http://www.google.com in eam, ut dictas disputando vim." & @CRLF & _
"NO TIRA: kuchnia.Na impedit ne, cu pri vęri nostro, mel ut integre praesent dissentias." & @CRLF & _
"TIRA UM: Ceteros inćorruptę google.com?sad=asd id, saępe ńullam vix ut." & @CRLF & _
"TIRA UM: Eam ut ępićurei adólesćens. Nam ąd sumo agąm. Vis te dicam https://www.google.com." & @CRLF & _
"TIRA UM: Has ęa, ei cóngue tęmpóribus comprehęnsam http://asdasd asdas da www.amazon.co.uk." & @CRLF & _
"NÃ TIRA: No nónumy doćtus sd.asd.comia uma pizza.nan asjJ.domain djJ.co asd.uk, altęra cónśetetur ut." & @CRLF & _
"SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam http:// asdasdasd . com Cu vix." & @CRLF & _
"SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam www . asdasdasd . com Cu vix." & @CRLF & _
"SECRETO: http:// www . alga-deweloper . pl sdsdfsdfsdf" & @CRLF & _
"NÃ TIRA: Altęra cónśetetur ut ?asd=asdd asdasd sdfsdfsdfsdf." & @CRLF & _
"TIRA UM: Ceteros inćorruptę http://www.google6.com#sdfsdf id, saępe ńullam vix ut." & @CRLF & _
"TIRA UM: Ceteros inćorruptę http://www.google6.com?asdads=asd&asasd=sdasd#sdfsdf id, ńullam vix ut." & @CRLF & _
"TIRA UM: Altęra cónśetetur www.donet.come sdffd. domain . com asdasd" & @CRLF & _
"TIRA UM: Altęra cónśetetur www.donet.come sdffd. www . aasd . com asdasd" & @CRLF & _
"TIRA UM: http:// www . alga-deweloper . pl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")