import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*access-list([^\\s]*\\s){1}(?<src_acl>[^\\s]+)\\s([^\\s]*\\s){2}(?<src_iface>[a-z]+)\\/(?<src_ip>[0-9.]+)\\((?<src_port>[0-9]+)\\)\\s->\\s(?<dest_iface>[a-z]+)\\/(?<dest_ip>[0-9.]+)\\((?<dest_port>[0-9]+)";
final String string = "Aug 28 16:02:42 dmzfw-cal.mgmt.biz.lodh.com Aug 28 2015 16:02:42: %ASA-4-106100: access-list acl_dmzout permitted tcp dmzout/192.168.200.20(46301) -> outside/74.120.148.12(80) hit-cnt 1 first hit [0x35de8ee6, 0x0]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}