#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^(?:(?:ию[нл]|январ|(?:апре|февра)л|(?:сент|окт|но|дек)[яа]бр)ь|(?:ма|авгу)(?:[рс]?т|й))$"
Local $sString = "Январь" & @CRLF & _
"Февраль" & @CRLF & _
"Март" & @CRLF & _
"Апрель" & @CRLF & _
"Май" & @CRLF & _
"Июнь" & @CRLF & _
"Июль" & @CRLF & _
"Август" & @CRLF & _
"Сентябрь" & @CRLF & _
"Октябрь" & @CRLF & _
"Ноябрь" & @CRLF & _
"Декабрь"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")